• 11Nov

    Natürlich nicht im direkten Sinne. Aber sie schicken immer mehr ältere Server in den verfrühten Ruhestand und helfen so beim Stromsparen. So geschehen am letzten Wochenende mit einem Webserver, der in immer kürzeren Abständen ausfiel. Dank fernschaltbarer Steckdose (mehr dazu demnächst) konnte er kurzfristig wieder zum Leben erweckt werden, aber als ich bei einem Ausfall gerade in der Nähe war und dann doch mal hingefahren bin, habe ich einen Blick ins Gehäuse geworfen. Es grüßten mich die üblichen Elkos mit „Hut hoch“…

    Defekte Elkos

    Defekte Elkos

    Zeitlich war das ganze etwas unpassend, aber was soll man machen. Eine gute Chance, die alte Mühle (Celeron 2,4 GHz, 512 MB RAM, aber immerhin 80er-Platten in HotSwap-Rahmen an einem 3ware PATA) zu virtualisieren. Der benachbarte XEN-Host hat noch genügend Luft 🙂

    Die Hoffnung, dass das Board das Kopieren der Daten übers Netzwerk noch durchhält, hat sich natürlich schnell zerschlagen. Also schnell die Platten in eine andere Maschine mit diesen Rahmen gesteckt (die leider somit zum Opfer wurde, sorry nochmal!) und wieder von CD gebootet. Folgendes Kommando hat dann gute Dienste geleistet:

    tar cf - . | ssh xenhost "(cd /mnt/temp && tar xvf - )"

    Natürlich war damit noch nicht alles getan. Als Linux kommt hier Ubuntu 8.04 Server zum Einsatz, es fehlte noch der passende XEN-Kernel. Beim Installieren (über einen anderen Server, schließlich lief dieser ja noch nicht!) wurde ich schon stutzig, als die Version 2.6.24-16-xen angezeigt wurde. Das wird doch nicht etwa immernoch…? DOCH! Noch immer gibt es keine Version des XEN-enabled Kernels in 8.04, die nicht mit dem Netzwerk-Bug daherkommt! Schlafen die eigentlich alle?

    Nur gut, dass ich diese Sache aus den Anfängen von 8.04 schon kannte. Schnell wieder den japanischen Patch gerausgesucht -> funktioniert. Danke!

    Permalink

    Tags: , , , ,