• 25Nov

    Was ist denn das für ein Titel?

    Naja, ich habe gerade ’ne OMA eingerichtet. Outlook Mobile Access 🙂

    Und dabei musste ich wieder an zwei DLLs denken, die mir irgendwann zu Zeiten von Windows 98 über den Weg gelaufen sind und die Nebenerwerbsgebiete großer Hersteller vermuten lassen: HPCOLA.DLL und MSOFEN.DLL!

    Komisch, auf den ersten Blick habe ich keine Sammlung von lustigen DLL-Namen im Netz gefunden. Es gibt doch sonst alles?!

    Permalink

    Tags:

  • 18Nov

    Heute stand mal wieder die Einrichtung einer Exchange-Umgebung an. Ich weiß schon, warum ich das letzte Mal in dieser Situation lieber den exzellenten Kerio MailServer eingesetzt habe…

    Die betreute Firma benutzt 4 bis 5 verschiedene Domains mit immer gleichen Mailkonten, und sowohl beim Senden als auch beim Empfangen soll ersichtlich sein, welche Domain nun gerade benutzt wird. Eigentlich kein Ding, oder? Tja, wer das denkt, kennt Exchange nicht. Oder kenne ich es nicht gut genug?

    Empfangen: OK, das mit dem schrottigen POP3-Connector im SBS 2003 muss ich keinem erzählen. Also mal wieder Cygwin mit cron und fetchmail eingerichtet. Die schöne Lösung mit Mailsammlung beim Provider und zentraler Abholung per UUCP ist leider nicht drin, weil der Provider nicht auf den schönen Namen Tigernet hört 😉

    Erste Idee: Ein Konto pro Benutzer mit allen dazugehörigen Mailadressen, gesammelte Zustellung durch fetchmail an diesen Account, und Server-Regeln zum Einsortieren der Mails in Domain-Unterordner. Das scheitert aber daran, dass Exchange die Information über die ursprüngliche Empfängeradresse nicht durchreicht – jedenfalls nicht so, dass man sie per Regel auswerten könnte. Eine eingehende Mail an xy@domain1.com ist also nicht von einer an xy@domain2.com zu unterscheiden.

    Also läuft es nun so: Mehrere Windows-Konten pro Benutzer, jeweils nach Maildomains aufgeteilt. Als Anhängsel zum Nachnamen gibt es „[Domain1]“ oder „[Domain2]“. fetchmail stellt an die jeweiligen Windows-Konten zu, und dort ist in den Zustelloptionen das eigentliche Hauptkonto als Ziel angegeben. So fließt die Domain in Form des Nachnamen-Anhängsels ein und ist für den Anwender sichtbar. Die Zusatzkonten werden in den Exchange-Adresslisten unsichtbar gemacht und stören so nicht weiter. Nicht schön, aber geht. Das hatten wir doch neulich erst!

    Senden: Auch nicht viel schöner. Man könnte ja denken, dass ein Benutzer alle seine zugewiesenen Mailadressen in einer Auswahlliste in Outlook zu sehen bekommt und dann auswählen kann, mit welcher Identität er gerade verschicken will. Das geht ja schließlich auch, wenn man mehrere POP3-Konten eingerichtet hat. Aber nein, das wäre ja viel zu einfach. Das geht nur mit Zusatztools von IvaSoft: SmartReply für Outlook (50$ pro Client) und ChooseFrom für Exchange (200$). Funktioniert gut, ist dem Kunden aber nicht zu vermitteln. Diese beiden Tools hätte Microsoft mal statt des POP3-Connectors kaufen und integrieren sollen!

    Was also tun, außer sich das Thunderbird-Feature mit mehreren Identitäten pro Konto zu wünschen? Mal wieder der alte Hack mit den Dummy-POP3-Konten, die nur zum Senden benutzt werden. *schüttel*

    So, genug Schauergeschichten für heute. Halloween ist schließlich schon lange vorbei!

    Permalink

    Tags: , , ,

  • 11Nov

    Natürlich nicht im direkten Sinne. Aber sie schicken immer mehr ältere Server in den verfrühten Ruhestand und helfen so beim Stromsparen. So geschehen am letzten Wochenende mit einem Webserver, der in immer kürzeren Abständen ausfiel. Dank fernschaltbarer Steckdose (mehr dazu demnächst) konnte er kurzfristig wieder zum Leben erweckt werden, aber als ich bei einem Ausfall gerade in der Nähe war und dann doch mal hingefahren bin, habe ich einen Blick ins Gehäuse geworfen. Es grüßten mich die üblichen Elkos mit „Hut hoch“…

    Defekte Elkos

    Defekte Elkos

    Zeitlich war das ganze etwas unpassend, aber was soll man machen. Eine gute Chance, die alte Mühle (Celeron 2,4 GHz, 512 MB RAM, aber immerhin 80er-Platten in HotSwap-Rahmen an einem 3ware PATA) zu virtualisieren. Der benachbarte XEN-Host hat noch genügend Luft 🙂

    Die Hoffnung, dass das Board das Kopieren der Daten übers Netzwerk noch durchhält, hat sich natürlich schnell zerschlagen. Also schnell die Platten in eine andere Maschine mit diesen Rahmen gesteckt (die leider somit zum Opfer wurde, sorry nochmal!) und wieder von CD gebootet. Folgendes Kommando hat dann gute Dienste geleistet:

    tar cf - . | ssh xenhost "(cd /mnt/temp && tar xvf - )"

    Natürlich war damit noch nicht alles getan. Als Linux kommt hier Ubuntu 8.04 Server zum Einsatz, es fehlte noch der passende XEN-Kernel. Beim Installieren (über einen anderen Server, schließlich lief dieser ja noch nicht!) wurde ich schon stutzig, als die Version 2.6.24-16-xen angezeigt wurde. Das wird doch nicht etwa immernoch…? DOCH! Noch immer gibt es keine Version des XEN-enabled Kernels in 8.04, die nicht mit dem Netzwerk-Bug daherkommt! Schlafen die eigentlich alle?

    Nur gut, dass ich diese Sache aus den Anfängen von 8.04 schon kannte. Schnell wieder den japanischen Patch gerausgesucht -> funktioniert. Danke!

    Permalink

    Tags: , , , ,

  • 01Nov

    Anforderung: Eine XEN-VM, die bisher als SSH-Login-Server benutzt wird, soll auch ein PPTP-VPN bereitstellen. Natürlich mit MPPE-128-Verschlüsselung, wozu will man auch sonst ein VPN haben.

    Idee: pptpd installieren, Konfiguration, Port 1723 und Protokoll GRE weiterleiten, fertig.

    Tja, denkste. Gentoo hat als modernsten Kernel mit XEN-Unterstützung die 2.6.18-xen-r12 im Angebot. Und was fehlt dort? Das Modul ppp_mppe bzw. die config-Option CONFIG_PPP_MPPE!

    Nächste Idee: ppp hat ein USE-Flag namens mppe_mppc, vielleicht bringt das ja etwas. Ein paar Kompilate später ist auch dieser Weg zu Ende. Das ist wohl ein alter Patch, der rein gar nichts bringt.

    Und nun? Vielleicht einen aktuellen Stanndardkernel von Gentoo nehmen und hoffen, dass er als XEN-DomU läuft? Pustekuchen, keine XEN-Unterstützung weit und breit. Immerhin hätte es hier ppp_mppe gegeben!

    Letztendlich habe ich einen Kernel aus Ubuntu 8.04 genommen (2.6.24-19-xen) und nutze diesen nun zum Booten der Gentoo-VM. Das funktionierte aber auch erst, nachdem in /sbin/rc ein paar Zeilen auskommentiert waren, die /proc und /sys einbinden wollen. Das erledigt nämlich der Ubuntu-Kernel schon vorher, also kam es zum Abbruch. Den Tipp habe ich hier gefunden.

    Fazit: Läuft, ist aber nicht schön. Aber es muss ja auch nicht immer alles schön sein. Man denke da nur an das unschöne 0:3 des großen beim kleinen HSV, das zeitgleich stattfand…

    Permalink

    Tags: , , , ,